(MAC) Build tree charts

150 150 Heredis - Help Knowledge Base

(MAC) Build tree charts

You can create as many graphical representations of your genealogy as you wish. A tree chart may be saved with the data it contains and its layout. It can then be reopened, modified in its presentation, print­ed again. It has become independent of the Heredis data file.
Choose Documents > Charts… or click Charts on the toolbar to visu­ally select the tree charts proposed by Heredis.

Edit a tree chart

The printing of a tree chart takes as its starting point the primary person displayed and will display his/her ancestors, descendants or both as an hourglass tree chart.

Choice of tree chart

Choose your tree chart and the theme

In the displayed selection screen, choose the type of tree to build from the list.
Heredis proposes various types of tree charts, the size of which is predefined (from A4 to A0 or Letter to Quad demy) but also tree charts of unlimited size. Whatever the type of tree chart selected, you can print it or have it printed over several pages or a single long strip of paper.
When a tree exceeds the size of your printer, each page is printed with an overlap to facilitate mounting of the chart.

Choice of theme

Click a theme in the coverflow. To facilitate your choice, Heredis dis­plays an overall preview of the tree to be edited with this theme and a preview of a box. Scroll through the different themes by pressing the arrow keys.
The last used themes are preset for each type of tree chart.

Chart Settings

Specify the construction parameters that suit you for the selected theme: number of generations, people to be displayed or not on the tree chart.

Tree charts of unlimited size
1. Indicate the number of generations. It may go up to 99 for ancestors as well as descendants.
2. Select Minimize Spacing for nesting boxes and rearranging space for the tree chart. If you do not tick this box, persons are drawn with respect to the axis of their parentage: those who are not direct rela­tives are never drawn one below the other.
3. Select the persons for inclusion on the tree chart. By default all per­sons appearing in the ancestry or descent of the primary person are displayed on the tree chart. You may untick secondary persons, or marked and confidential persons, for them not to be displayed on the tree chart. You may also hide all the data you have declared to be pri­vate (events, pictures, etc.).

Tree charts of a predetermined size
1. Indicate the number of generations, which may range from 4 to 8 depending on the type of tree chart and the theme selected in the Chart Settings field.
2. Select the persons to be included on the tree chart. By default all persons included in the ancestry of the primary person are displayed on the tree chart. You may untick marked, secondary or confidential persons. You may also not display private data.
Click OK to start the display of the tree chart.


Tree Chart Screen

Heredis displays a tree chart representing the lineage of the prima­ry person and which is printable immediately. If you want to make changes to the tree chart, you have tools in the form of removable panels specific to the various tree charts.

Toolbars and Menus

When the tree chart is displayed, the menus and buttons are different from those for data management.
Use the New – Open – Save – Page Setup – Print buttons for nor­mal actions.

Display the buttons you most often use by choosing right click on the toolbar then Customize toolbar.

Use the tree chart menus to manage also the layout of the screen or the selection of people on the tree chart.
Info • You can create a new tree chart while an existing tree chart is already on the screen. Click the New button on the chart toolbar and select a new type of tree chart and a new theme, or choose File > New.

Persons Panel

The Persons panel of the tree chart contains a list of all individuals included in the chart. Clicking a person in the list previews that per­son’s box in the tree chart. A double click navigates through the tree, if its size exceeds that of the screen, to display the box for a selected person.
To quickly find a person in the list of individuals on the tree chart, enter the surname and/or one or more given names. Refine the search by selecting from the pop-up menu, the gender of the person sought if the name is multiple.
When there are marriages between blood relations (implex) on your tree chart, certain ancestors may be included more than once. Heredis will only display one complete branch and duplicate branch­es are cut off. You may locate implex ancestors in the list because they are displayed in gray. Click the name in black to display the whole branch. Click the name in gray to display other locations of this ancestor on the tree chart. Their boxes have identical implex let­tering.

Info • In the tree chart, click the implex lettering of the box to navi­gate to the other box of the implex ancestor.

The Data panel shows you a summary of the person whose box is selected. All information displayed here may appear in the box according to the type of content selected.
The Preview panel shows the selected box. At the opening of the tree chart, Heredis displays a complete view of the document, whatev­er its size. The preview is very useful in large tree charts, when the content of the boxes is not readable on the screen. This visualization immediately displays any changes that you apply to the box.

Settings Panels

You may modify the unlimited tree charts to give them a more per­sonal graphical appearance. In the fixed size tree charts, the changes apply only to the content of the boxes. The visual environment is not editable.
These panels allow either changes to be applied to the whole tree chart or changes to a given selection (one or more boxes).

Display screen

The central area of the screen shows all the boxes of the tree chart, the background image and the frame of the tree chart.
To help you check and estimate the size of your tree chart, material­ize the pages on the screen.
Unfold the Print Setup panel and select Show Page Breaks or choose View > Show Page Breaks.
The number of pages depends on the chosen page format for your printer. To change the format and page orientation in your printer, click the Page Setup button or choose Page Setup .
To move around the tree chart, use the horizontal and vertical bars, or change the zoom factor or double-click the name of a person from the Persons panel to display his/her box directly.

Zoom

You can increase (zoom in) or reduce (zoom out) the display of the tree chart. It is often necessary to reduce the display of a tree chart to visualize all required generations.
Choose View > Zoom > Increase Magnification or View > Zoom > Decrease Magnification. To return to the actual size of the tree, choose View > Zoom > Actual Size.
You may also select different levels of zoom on the bottom bar of the tree chart screen.
• Select a value from the pop-up menu or use the slider to change the zoom level. Heredis indicates the factor used to reduce or enlarge to the right of the cursor.
• Click the 100% button to return to the real size of the tree.
• Hold down the Option ( ) key and the cursor takes the form of a magnifying glass. With a left click, the tree chart grows, with a right click, the tree chart is reduced. You may also drag the mouse around a group of boxes to increase their size or use the mouse wheel up or down to enlarge or reduce.
Info • Remember to display the tree chart in full screen mode to have as much room as possible: click the Full Screen icon (green) on the screen bar of the tree chart.

Selection

Before making changes to a tree chart, first select the boxes to which they will apply. Depending on the type of change to be made, make individual selections or selections of a genealogical order.

  • To select all boxes of the tree chart, choose Select > Select All. From anywhere in the tree chart, you can right-click the mouse and choose Select All.
  • To select one or more boxes of the tree chart, drag the mouse cursor over the boxes to be selected.
  • To select more boxes that are not contiguous, select the first box, and then, holding down the Command ( ) key, the additional box or boxes.
  • To make genealogical selections from any box in the tree, right-click the mouse and choose Select Men Only (or Women Only, or Person and All Ancestors, or Person and All Descendants or Generation).

Info • Persons corresponding to the selected boxes are also selected in the Persons panel.


Format the tree chart

To make changes, display the tree chart panel column and the Whole Chart and Selected Items by clicking the disclosure triangle.

Tree chart of predetermined size (Single-page Chart, Designed Chart, Fan Chart)

Designed Chart

The changes apply to the selected boxes. The formatting of the text is customizable, but the visual environment cannot be changed.

Modify the contents of boxes selected

Click the Selected items tab, then click the Modify button (eye icon) to select the new content for the box. In the sheet which appears, click the arrows field to reveal the possible content for the type of tree chart displayed.


Click OK, and the new content is applied to the selected boxes.
Info • For each box of the tree chart, you know the information that can be displayed. Unfold the Data panel to view them.

Change the text formatting

1. Without delay, change the font, size, color and text alignment with the pop-up menu, the cursor and the buttons.
Info • Do not forget that you can make a selection of all men in the tree chart, then all women, to apply different text colors. For this, use the Select menu or right-click of the mouse.
2. Tick the Picture box to add the photo for the persons in all the selected boxes and format the photos.
Select the position of the picture relative to box text by clicking the buttons. Change the size of the picture with the cursor. Select the type of border for the picture.
No Boder: the image is displayed as you scanned it.
Border Style: click the color box to choose a color for the border. Change its width with the cursor.
Frame Style: click the Modify button (eye icon) to select another frame image for the photo. In the panel which appears, use the arrow keys to display the various frames proposed. Click OK to apply.

Modify the fan tree charts

The fan tree charts propose the feature of being able to highlight a branch by shifting the alignment of generations.
1. Select the box at the base of the branch you want to highlight, start­ing from the second generation.
2. Click the Box tab in the Selected Items panel.
3. Tick the Move Branch Forward box.
4. To cancel the move of the branch, click any other box of the branch that was moved and untick the Move Branch Forward box.

Changes made to the chart are displayed immediately.

Unlimited tree charts (Unlimited ancestors chart, Descendants Tree Chart, Hourglass Tree Chart)

Hourglass Chart

 

Change the layout of the tree

1. Click the Layout tab on the Whole Chart panel.


2. Change the space between the boxes or the spacing between gener­ations by using the sliders.
3. Tick the Display Empty Lines box for all boxes to be filled with the same number of lines, even if you do not have information.
4. Click the Center Tree Chart button to reposition it optimally after modifications.
5. Click Move Overlapping Boxes to reconstruct the tree chart, pre­venting boxes from straddling over two pages. The tree chart layout is thus facilitated since only connecting lines between the boxes require adjustment.
6. Change, if necessary, the width of all boxes of the tree chart with the cursor. If the selected theme contains boxes of varying sizes, to suit to the data contained, select Make All Boxes Similar and specify the desired width with the cursor.

Move elements in the tree chart

After selecting boxes, several methods for moving them are avail­able. Choose the one that suits you best.
• Mouse: Drag the selection to its destination by holding the mouse button pressed.
Info • Hold down the Shift key to prevent any movement off the generation axis. Each box moved will remain aligned with the other boxes in the same generation.
• Arrow keys: press the arrow keys to move to the position you wish to select.

To cancel the moving of the selection, press Command ( )-Z or choose Edit > Undo.
To restore the move, press Shift-Command ( )-Z or choose Edit > Redo.

 

Change the design of the tree chart

Change the graphical appearance of your tree charts with a few clicks. Some graphical changes apply to the whole tree chart, others apply only to the boxes you selected.

1. Click the Design tab in the Whole Chart panel.


2. Display the frame of the tree as well as the background pattern by clicking the Frame and Background tick boxes. Change the frame size of the tree with the cursor.
3. Tick the Shadow box to add a shadow to all the boxes on the tree chart. Turn the rotary tool to indicate the axis of the shadow and specify its opacity by typing directly into the input field or by using the arrows to increase or decrease it. Change the width of the shad­ow with the cursor.
4. Tick the Silhouette for Missing Media box for all boxes of the tree chart to have an image. Heredis draws the silhouette of a man or a woman for the persons to whom you have no assigned image.

Change the tree chart boxes

All boxes of a tree chart may be modified individually or overall.

1. Select the boxes to be changed and unfold the Selected Items panel.


2. Click the Box tab.
3. Change the width of the boxes selected with the cursor. If the boxes are not of a fixed size, the change will be proportional to the initial size of each box.
4. Choose the type of background: None, Color Fill, Gradient Fill or Picture. The tools vary depending on the type selected.

  • None: the text appears directly on the tree chart box and the box is transparent.
  • Color Fill: click the color box to choose a color.
  • Gradient Fill: click in each of the color fields to choose the start and finish colors. Click the arrows to reverse the gradient in the box. Turn the rotary tool to indicate the gradient axis.
  • Picture: click the Modify button (eye icon) to select a new back­ground image for the box.

5. Choose the type of border for the box: None, Line or Frame. Specify the appearance of the border according to the type selected.

  • None: the box is not bordered.
  • Line: select a form of border (straight or rounded corners). Click the color box to choose a hue in the color panel. Use the slider to set the width of the border.
  • Frame: click the Modify button (eye icon) to select a new frame image for the box. Use the slider to set the width of the frame.

Info • You may only apply borders to drawn boxes. The background images of the box must contain a border in the image.

6. Indicate whether the selected boxes should be turned. To change the axis of the selected boxes, use the cursor or select a value from the pop-up menu.
All changes are immediately displayed on the tree chart.

Modify the content

You have the same tools as for tree charts of predetermined size.
Click the Contents tab to apply to the selected boxes.

Modify connecting lines

1. Click the Lines tab.
2. Choose the type of line to connect the selected boxes from the pop-up menu: right angles, rounded corners or curves.
3. Select a line style from the pop-up menu.
4. Specify the width of the connecting line with the cursor and click the color box to choose a color.

All changes are immediately displayed on the tree chart.

Edit the text of a box

1. Double-click the box to be edited to open the editing field.
Info • You can only edit one box at a time.
2. Enter changes to the displayed text.
3. Click OK to apply changes.


Print the tree chart

Adjust the size of a tree chart

Before printing, you must make sure that the size and orientation of the paper are set as you wish.

1. Choose File > Page Setup or unfold the Print Setup panel and then click Page Setup.
2. Select the printer you will use in the Format For menu.
3. Choose a standard paper size in the Paper Size menu. If you want to select a customized paper size, choose Manage Custom Sizes from the menu.
4. Click the button corresponding to the desired orientation.
5. If necessary, enter a percentage in the Scale field. A value below 100% reduces the image, a value greater than 100% enlarges it.
6. Click OK to confirm the print size.

If the tree is too large, you may change its size by reducing the num­ber of pages in the Print Setup panel.
1. Tick the Show Page Breaks box. Heredis displays how many pages corresponding to the selected paper size will be needed to print the tree chart.
2. Change the number of pages in width and/or height.
3. To enlarge or reduce the overall size of the tree chart, enter a per­centage in the Scale field or move the cursor. A value below 100% reduces the size of the tree chart, a value greater than 100% enlarges it.

Info • Modification of the print setup may require the moving of new overlapping boxes.

It only remains to launch the printing of the tree chart.

Launching the print-out

Depending on the printer you are using, you can print the tree on one page or series of pages to be assembled together.
1. Click the Print button on the toolbar or choose File > Print.
2. Select the printer you want to use from the list of available printers. If your printer does not appear, select Add Printer from the Printer menu.
Info • For more information on adding a printer, look for Add Printer in the Mac Help.
3. To get a preview of the pages to be printed, click the scroll arrows.
4. Click Print.


Export a tree chart

Export the displayed tree to get it printed by a professional or share your Heredis trees with people who do not have the software. Heredis constructs a tree chart using a file format that is likely to be used on other computers or devices in the form of a readable file.

1. Click the Print button on the toolbar or choose File > Print.
2. Click the PDF pop-up menu and select Save as PDF…
3. Choose the location where the tree file in PDF format will be saved. If your file directory is not visible, click the disclosure triangle to the right of Save As.
4. Click Save.

Info • According to your work habits, you may save the tree chart in PDF format directly to iPhoto or Aperture, or transform the tree chart in JPG or TIFF images.


Save the tree chart

Save the tree charts created with Heredis. You may modify or print them later.

Saving a tree chart for the first time

1. Click the Save button, choose File > Save or press Command ( )-S.
2. In the Save As field, change the name of the tree chart if necessary.
3. Choose the location where the tree chart should be saved. If your file directory is not visible, click the disclosure triangle to the right of Save As.
4. Click Save.

Info • The tree is saved with the main data displayed for each person. Even if some data are not shown in the boxes at the time of saving, they can be used when the tree is reopened. For example you could apply a more detailed content to the boxes of the tree chart even if it was built with minimum content.

After saving your tree chart for the first time, click again the Save button or press Command ( )-S to save it as you work.
To obtain a copy of the tree chart and make further changes, select Save > Save as or press Shift-Command ( )-S.

Reopen a saved tree chart

To reopen a saved tree chart and make further changes or print it, choose File > Open in a tree chart screen.
You can also open a saved tree chart from the Heredis home page. Select Open > Chart File.
Choose the location in your file directory and click Open.