Customize Heredis

150 150 Heredis - Help Knowledge Base

Customize Heredis

You may adapt Heredis to your personal work methods.

Choose your color theme

You spend many hours in front of your Heredis screen? Select the color of the environment that is best suited to your eyes and your taste.

Click Window(s) Menu > Theme
Click the Themes button to change the color of the main Heredis screens.


Select the Toolbar

Click Customize button to select the tools you need.

  • Choose an icon and drag it to your toolbar at the desired location or click on the Add button. To remove an icon, (Mac) drag it out of the toolbar, (PC) click on the Hide button.
  • Drag the icons and place them in the order you want, (PC) or click on the Before and After buttons. You can also add extra spaces between the buttons.
  • To display the buttons as they were when Heredis was first launched, drag the default set to the toolbar.

You need more space? Then change the display format of the icons.

(PC) Tick or Untick Big Icons and Icons and Text.
(Mac) Select Icon only from the Show pop-up menu and click Use small size.


Customize the panels

Display or hide the panels

Certain panels are of no use to you? Click the closure button and they will disappear from the column.

(PC) You can hide or display the Search and Tools panels on one side or the other of the screen. Click the arrow at the top of the panels  to open or close them or choose Windows > Show/Hide Tools Panels, or Show/Hide Search panels, or One panel at a time. You can also swap the panels.

(Mac) Use the buttons at the bottom of the screen to change the display of panels. The arrow button to the right or left will show or hide the column or columns of panels. The indented wheel button at bottom right will give you access to any panels which have been removed. A simple click will display the panel again.
The procedure for opening the panels may be different for each col­umn. Select Open one panel at a time and the panel which is open will automatically close when another panel is opened in the same column. Otherwise the panels will remain open as long as you have not clicked the disclosure triangle.
Add a column of panels if you want to have more information simul­taneously displayed.
You may reposition a panel in the column or to another column using the mouse. Its new position is indicated by a blue line and then release the mouse to place it there.
You may alter column width and height of panels if necessary. The cursor will change when placed at the limit of the bar and you may then drag to resize the panel or column.

Resize the panels

(PC) They are resizable in width. Click on the line between panel/navigation screen. The cursor shape will change and you may increase or decrease the proportion of the screen allocated to the panels. The display area of the panel is vertically adjustable in the same way.

(Mac) The space allocated to the display of panels may be altered: click the separation line between two panels. The cursor changes to a directional cross and you can extend or shrink the area shown above. Click the separation zone between the panel columns and the file display area to change the space allocated to the panels.

Arrange the panels

(PC) They may be positioned to the right or left of the navigation screen. You can change their position by using the menu Windows > Swap Tools and Search panels. Select Open one panel at a time in the Windows menu. Heredis automatically closes the open panel when you click the arrow to display the other panel.

(Mac) 1. Move the panels by using drag and drop.
2. Click the top bar of the panel and drag to the desired location for the panel in any panel column.
3. When the desired destination is highlighted by a blue line, release the mouse.

Choose Open One Panel at a Time by using the Options panel button. Heredis automatically closes the displayed panel when you click the display triangle of another panel.


Heredis’ Preferences

Define your preferences

In the (PC) Tools > Preferences > Heredis Preferences menu, (Mac) Preferences, you may define the formats of all the various input fields. Choose how to display the names, places, numbers. Choose the default options for creating events and set inconsistency alerts. Heredis gives you access to advanced configuration options. You must change them only if you are blocked using the default preferences.
• Deactivate Hardware Acceleration: Check this option if you have problems displaying the Online Archive
• Enable file storage: this option optimizes the overall operation of the Heredis software and gives you more fluidity when browsing, optimized search times, faster entries.
Uncheck this option if you notice a marked slowdown in the application when saving your file.
Note: If you change an option, remember to quit and restart Heredis for the new options to take effect.

PC’s Heredis Preferences

 

 

Mac’s Heredis Preferences

 

Automatic formatting of data

When you enter a surname or given names, you can type them in either uppercase or lowercase. If the Uppercase option has been selected in Preferences ((PC) you will find it in the Tools Menu), a surname or a given name typed in lower case will be automatically converted to uppercase, including accented characters. If the name contains a particle it will remain in lowercase.
If you have chosen in Preferences the Initial Caps option, the surname or given name’s first letter will be automatically converted to upper case, including accented characters.

Choose the recognized places

Because your ancestors probably lived in your home country or are from a limited number of other countries, you can limit the list of countries for which places will be suggested during the data entry.
1. Choose Preferences Countries.
2. Check the different countries where you are likely to have places to enter.
The places proposed during data entry in the Add or Choose…, Personal DataFamily Group Data or Places Index tabs will be limited to those countries.

Info • The proposed geolocations relate to the whole world and are not limited to countries ticked in the Preferences menu.

Select data entry method

Heredis allows you to display only the information that you commonly use. This visual selection mode in no way changes your data, which are still preserved whether or not you display them. You can change the data entry mode at any time.

Depending on whether or not you have a complete deed or just a mention on a website, you will not need the same input fields. This is why the Heredis data entry fields are modular. There are three data entry modes (BasicComprehensiveCustomized) that you may use in different ways depending on the data input screen (Add or Choose… screen, Personal Data tab, Family Group Data tab).

Prepare the data entry screen to your liking by using the Customize view. Each data entry screen will then display the selected items.

In Basic mode, the information displayed is by default. This mode displays only the main fields. You can change the data input mode at any time.

Check the items not displayed

If you choose the Basic or Customized display modes, it may hap­pen that certain information entered does not appear. Heredis alerts you by displaying an alert triangle  next to the indented wheel icon (Choose data fields you wish to use).
Click the alert triangle: the display is changed temporarily and all saved data items are displayed.
When you navigate to another person, the data items are again hid­den in accordance with the mode you have chosen.

Completeness of data

The icon  indicates whether or not essential information for major life events is complete (Birth, Marriage, Death).
This icon concerns the completeness of information for the primary person in the Status bar and in the Search tab. It appears also in the Persons and Branches panels for all individuals displayed.

The icon display is defined in Heredis> Preferences> Appearance. You can choose what information is required for an event to be com­plete: the accuracy of the date, place, the presence of a source and the status of the search for the event.

Regardless of the information collected in Heredis, you may deter­mine that certain individuals will not require further research. Open the Search tab and click the  Consider that this individual is com­plete button. The icon changes color.

When using the Branches panel, choose the Complete Persons Only option, and the results take into account both the completeness of the events and the individuals for whom you had determined that they be considered complete.